Categories
tr

Java Silverlight ve diğer eklentiler modern tarayıcılarda nasıl kullanılır?

Çoğu tarayıcı üreticisi Java, Flash ve Silverlight ya da Quicktime gibi diğer eklentiler için desteği bırakmayı planlasa veya bu teknolojileri desteklemeyi çoktan durdurmuş olsa da, hâlâ yalnızca belirli eklentiler yüklendiğinde erişilebilen birçok site ve hizmet var. tarayıcıda.

Örneğin Google Chrome’u alırsanız, teknolojinin yerel entegrasyonu sayesinde Flash’ı desteklediğini ancak başka bir eklenti içermediğini hemen fark edeceksiniz. Bu, Chrome kullanıcılarının Internet’te Silverlight, Java veya diğer eklentileri gerektiren içeriğe erişemeyeceği anlamına gelir.

Microsoft, Windows 10’da Edge’i bu eklentileri desteklemeden yarattı ve yerel bir entegrasyon sayesinde yalnızca Flash’ı destekliyor, ancak başka bir eklentiyi desteklemiyor.

Mozilla Firefox ise eklentileri destekliyor, ancak Mozilla eninde sonunda desteği bırakmayı planlıyor (muhtemelen 2017’de).

Bazı servislerin ve sitelerin hala bunlara ihtiyaç duyduğunu düşünürsek, muhtemelen tarayıcının bu eklentiler için neden bırakma desteği verdiğini merak ediyorsunuzdur. Cevap, tarayıcının güvenliği ve kararlılığı için faydalı olmasıdır.

Mozilla’nın yedi gün boyunca topladığı Firefox 45. 0. 2 çökme istatistiklerini kontrol ederseniz, ilk on kilitlenmeden dördünün eklentilerle ilişkilendirildiğini göreceksiniz (konum 2, 4, 5 ve 9).

bu konuda ne yapabilirsin

İnternet kullanıcıları, en azından masaüstü bilgisayar kullananlar, iki sorunla karşılaşır:

  1. Sistemde eklentiler kullanıldığında/yüklendiğinde kararlılık ve güvenlik sorunlarıyla ilgilenin.
  2. Eklenti gerektiren içeriğe erişilebildiğinden emin olun.

Eklentileri destekleyen bir tarayıcı çalıştırıp bununla işiniz bitebilirken, bunun yerine ikincil bir tarayıcı kullanmanızı öneririm.

Ana tarayıcınız artık eklentileri desteklemiyorsa, bu aynı zamanda tek seçenektir.

Ek olarak, ana tarayıcınız eklentileri destekliyorsa, eklenti içeriğini diğer her şeyden ayırmak, yukarıda belirtilen ilk sorunla ilgilenir.

Bir video akışı sitesi veya çevrimiçi bankacılık sitesi gibi yalnızca eklenti gerektiren sitelere bağlanmak için kullandığınız için, ana tarayıcınız kararlılık sorunları yaşamaz veya eklentileri hedef alan saldırıların kurbanı olma riskiyle karşı karşıya kalmaz.

tarayıcı

Eklentiler için eksik destek nedeniyle birkaç tarayıcı bunun için kullanılamaz. Buna Google Chrome ve Vivaldi veya Opera ve Microsoft Edge gibi diğer Chromium tabanlı tarayıcılar dahildir.

GÜNCELLEME: Eklentilerin Firefox Web tarayıcısında da çıktığını lütfen unutmayın. NPAPI eklentilerini desteklemeye devam ettiği için bu durumda Pale Moon gibi bir tarayıcı kullanabilirsiniz. SON

Bu, Mozilla Firefox’u (veya Firefox tabanlı bir tarayıcı) veya Internet Explorer’ı bırakır ve her ikisi de iyi çalışsa da, tarayıcının ikinci bir kopyasını kolayca yükleyebileceğiniz için bunun için Firefox’u seçmenizi öneririm veya sadece başka bir profil kullanmanızı öneririm. Eklenti ile ilgili içerik için.

Benim önerim, tarayıcının genişletilmiş bir destek sürümü olan Firefox ESR olacak. Önerinin nedeni, ESR’nin güvenlik güncellemeleri ve hata düzeltmeleri ile düzenli olarak güncellenmesidir, ancak sadece her sekiz sürüm döngüsünün önemli özellik güncellemeleri ile güncellenmesidir.

Bu, eklenti desteği ile ilgili olarak tarayıcının normal sürümlerinden daha fazla zaman vermelidir. Ayrıca, yeni sürümler yayınlandığında tarayıcıya yapılan değişikliklerle uğraşmak zorunda değilsiniz.

Alternatif olarak, tarayıcının yüklü kopyalarından tamamen bağımsız olarak çalıştırmak için Firefox’un taşınabilir bir sürümünü de indirebilirsiniz.

Kurmak

Resmi web sitesinden Firefox ESR’yi indirin ve yükleyin. 32 bit sürümü indirdiğinizden ve kullandığınızdan emin olun, çünkü 64 bit sürüm olarak birçok eklenti mevcut değildir.

Ana tarayıcınız Firefox değilse, aşağıdaki adımı atlayın.

Firefox’un başka bir kopyası zaten çalışıyorsa Firefox ESR çalıştıramazsınız. Bunu aşmak için aşağıdakileri yapın:

  1. Firefox’un tüm sürümlerini kapatın.
  2. Firefox ESR’yi parametrelerle çalıştırın. Kurulum sırasında bir masaüstü simgesi yerleştirdiyseniz, üzerine sağ tıklayabilir ve parametreleri hedef çizginin sonuna ekleyebilirsiniz.
  3. Profil seçim ekranı görünmelidir.
  4. Profil Oluştur’u seçin ve talimatları izleyin. Profil için tanımlayıcı bir isim seçmenizi öneririm, ör. Firefox eklentileri etkin.
  5. Yapıldıktan sonra tarayıcıyı kapatın ve kısayolun u-p “Firefox eklentileri Etkin” – – N o-Remote olarak düzenleyin. Bu, tarayıcıyı her seferinde her seferinde profil yöneticisini kullanmak zorunda kalmadan doğrudan yeni oluşturulan profili kullanarak çalıştırabilmenizi sağlar.

Artık Firefox kurulduğuna göre, eklentileri sisteme yükleme zamanı.

Eklenti İndir bağlantıları

Aşağıda, popüler eklentiler için indirme bağlantıları vardır:

  1. Adobe Flash (İndirme sayfasında üçüncü taraf tekliflerini işaretlemenizden emin olun)
  2. Java
  3. Microsoft Silverlight (Bing’i arama motorumu yapmanın ve kurulum sırasında MSN’yi ana sayfam haline getirdiğinizden emin olun).

Kurulum ve Yapılandırma

Eklentileri ihtiyacınız olan sisteme yükleyin. Yapıldıktan sonra, bu eklentileri yalnızca Firefox ESR sürümünüzü çalıştırdığınızda etkinleştirilecek şekilde diğer tarayıcılardaki engellemeniz gerekebilir.

Başka bir Firefox sürümü kullanıyorsanız, tarayıcıdaki eklentiler hakkında yükleyin, eklentilere geçin ve sayfada bulduğunuz tüm eklentileri “Asla Etkinleştir” olarak ayarlayın.

In Internet Explorer, tap on the Alt-key, and select Tools >Eklentileri yönetin. Yüklü herhangi bir eklentiyi bulun ve kullanılmadığından emin olmak için sayfada devre dışı bırakın.

Hiç tarayıcı kullanmasanız bile bunu yapmanızı öneririm.

Kullanım

Şimdi geriye kalan tek şey, internette eklentiler gerektiren içeriğe ve kalan etkinlik için başka bir tarayıcı erişmeniz gerektiğinde eklenti destekleyici tarayıcı kullandığınızdan emin olmaktır.

Şimdi siz: Hala eklentilere ihtiyacınız var mı?

Firefox sürüm 52 7 Mart 2017’de yayınlandığından, Adobe Flash Player hariç Firefox’ta yüklü NPAPI eklentileri desteklenmedi. Bilgisayarınıza yüklenmiş olsalar bile, artık Firefox’a yüklenmeyen eklentilerden bazıları Java, Microsoft Silverlight ve Adobe Acrobat’ı içerir.

Son birkaç yıldır, Firefox, web sitelerinin eklenti olmadan her zaman yaptıkları şeyleri yapabilmeleri için çeşitli web API’leri uyguladı, bu nedenle tarama deneyiminizde herhangi bir değişiklik fark etmeyeceksiniz.

İnternet, video, ses ve oyunlar gibi statik sayfaların ötesine geçen web siteleriyle doludur. NPAPI eklentileri, özellikle Flash, bu etkileşimli sayfaların etkinleştirilmesine yardımcı olsa da, taramalarınızı daha yavaş, daha az güvenli ve çarpma olasılığınızı daha yüksek hale getirir.

Son birkaç yıldır, Firefox bu eklentiler için yedekler oluşturmak için çok çalıştı, bu yedeklere Web API’ları denir. Web API’leri, İnternet güvenliğinizi, istikrarınızı ve performansınızı baltalamadan NPAPI eklentilerinin işlevini değiştirmek için tasarlanmıştır.

Daha önce, bu web API’leri oldukça hazır olmasa da, Firefox eklentileri manuel olarak yükleyerek geçiş yapmaya başladı (etkinleştirmek için tıklayın).

Şimdi, birçok site web API’lerini benimsedi ve neredeyse tüm favori sayfalarınız eski ve güvensiz eklentiler kullanmadan çıkarılabilir. Firefox, bu NPAPI eklentileri için desteği kaldırarak Google Chrome ve Microsoft Edge gibi diğer modern tarayıcılara katılır.

Mümkünse Firefox’u güncellemenizi öneririz.

Firefox’un her güncellemesi, internette güvende tutmanıza yardımcı olan iyileştirmeler de dahil olmak üzere önemli düzeltmeler ve iyileştirmeler içerir. Firefox da dahil olmak üzere herhangi bir tarayıcının eski bir sürümünü kullanmak, kişisel verilerinizi ve hatta bilgisayarınızı riske atar.

Firefox, eklentiler gerektiren özellikleri desteklemek için genişledi. Eklentiler, bunun üzerine, otomatik olarak güncel tutulur ve ek güvenlik için blok listesi yoluyla yönetilir. Böylece sadece bir Firefox güncellemesiyle güncel kalabilirsiniz.

Bu iyi insanlar bu makaleyi yazmaya yardımcı oldu:

Gönüllü olmak

Büyüyün ve uzmanlığınızı başkalarıyla paylaşın. Soruları cevaplayın ve bilgi tabanımızı geliştirin.

Önkoşul: Java Öğreticileri

Bu makale Java’nın tarayıcılara desteği ile ilgilidir.

Neden bir tarayıcıda Java desteğine ihtiyacımız var?

Biraz bilginiz varsa veya Java’da çalıştıysanız veya çalıştıysanız, bu Java uygulaması kavramıyla karşılaşmanız muhtemeldir. Yani, bir uygulama bir Java programından başka bir şey değildir, ancak tek fark doğrudan bağımsız bir makinede çalışamamasıdır. Çalışması için bir web tarayıcısına ihtiyacı var. Bir HTML sayfasına kolayca gömülebilir ve istemci tarafı bir konsept, yani istemci tarafında çalışır.

Bu nedenle, uygulamayı çalıştırmak için Java özellikli bir tarayıcıya ihtiyacımız var. Tarayıcılar, üzerinde bir uygulamanın yürütülmesine izin veren bir Java eklentisi ile birlikte gelir. Ve böylece, Java etkinleştirilen tarayıcılar, herhangi bir güçlük olmadan uygulamayı çalıştırabilir.

Şimdi, Java için neden tarayıcı desteğine ihtiyacımız olduğunu bildiğimize göre, bugün destekleyen tarayıcılar listesi ile başlayalım.

JAVA: Tarayıcıları destekleyen tarayıcı, NPAPI’ye (Netscape Eklenti Uygulama Programlama Arayüzü) bağlı Java eklentisine ihtiyaç duyar. Bugün, tanınmış tarayıcıların çoğunluğu bunun desteğini düşürdü.

İşte Java uygulamasını artık desteklemeyen tarayıcılar:

  • Google Chrome
  • Firefox
  • Safari
  • Microsoft Edge
  • Opera

Gördüğünüz gibi, tüm bu tarayıcıların uygulamayı daha uzun süre desteklemediğini. Oracle’ın JDK’sının daha yeni sürümleri bile Java tarayıcı eklentisinin desteğiyle gelmiyor.

Desteği bırakmanın nedeni, güvenlik sorunları ve bulunan risklerden kaynaklanıyordu.

Ancak Java uygulaması için hala desteğe sahip Internet Explorer var. Yani, bugün Internet Explorer, Java uygulamasını destekleyen tek tarayıcıdır.

İnternet explorer’da java nasıl etkinleştirilir? İnternet Explorer’da Java’yı etkinleştirme adımları aşağıdadır:

  1. Pencerenin sağ üst köşesindeki ‘Araçlar’ simgesini tıklayın veya Windows’ta ise Alt+X tuşuna basın.
  2. Ardından “İnternet Seçenekleri” ni seçin.
  3. Ardından ‘Güvenlik’ sekmesinde ‘Özel Seviye’yi tıklayın.
  4. Şimdi, açılır pencerede aşağı kaydırın ve ‘Java uygulamasının komut dosyası’ arayın ve etkin olduğundan emin olun ve Tamam’ı tıklayın.

Sử dụng internet explorer (ngay cả trên windows 10)

Internet Explorer là trình duyệt cũ của Microsoft và Microsoft vẫn hỗ trợ nó với các bản cập nhật bảo mật. Ngay cả trên Windows 10, nơi Microsoft Edge là trình duyệt web mặc định, Microsoft vẫn bao gồm phiên bản Internet Explorer 11 cũ cho mục đích tương thích. Điều này rất quan trọng vì Microsoft Edge, trình duyệt hiện đại của Microsoft, không hỗ trợ bất kỳ plugin dựa trên ActiveX nào. Nó chỉ hỗ trợ phiên bản Adobe Flash tích hợp của riêng nó. Cho dù bạn đang sử dụng Windows 7, 8 hoặc 10, bạn sẽ tìm thấy Internet Explorer trong menu Bắt đầu. Trên Windows 10, bạn sẽ thấy nó bị ẩn trong Bắt đầu> Phụ kiện Windows> Internet Explorer. Nếu bạn sử dụng Microsoft Edge, bạn có thể nhấp vào menu> Mở bằng Internet Explorer trên bất kỳ trang web nào để nhanh chóng mở trang web đó trong Internet Explorer. Có thể bạn sẽ không muốn sử dụng Internet Explorer làm trình duyệt của mình mọi lúc, nhưng bạn có thể khởi chạy nó bất cứ khi nào bạn cần sử dụng trang web yêu cầu plugin. Để cài đặt các plugin này, chỉ cần khởi chạy IE và truy cập trang web thích hợp – trang web Java của Oracle hoặc trang web Silverlight của Microsoft, ví dụ:. Nếu Java không chạy đúng cách, hãy đảm bảo plugin trình duyệt được bật trong bảng điều khiển của nó. Bạn sẽ tìm thấy bảng điều khiển Java tại Bảng điều khiển> Chương trình>Java. Güvenlik Güvenliği sekmesinde, tarayıcıdaki Java içeriğini etkinleştirmeyi etkinleştirin. Bu ayarları değiştirdikten sonra tarayıcınızı yeniden başlatmanız gerekebilir. Internet Explorer 11 ile çalışmayan ve Internet Explorer’ın eski bir sürümünü gerektiren eski bir web sitesini ziyaret etmeniz gerekiyorsa, Internet Explorer 11’in iş modunu kullanabilirsiniz. Ancak bu, Windows 10’un profesyonel sürümünü gerektirir. Ev versiyonunda mevcuttur.

Mozilla Firefox ESR’yi Windows, MacOS veya Linux’a yükleyin

Mozilla đã kết thúc hỗ trợ cho các plugin trình duyệt NPAPI truyền thống, ngoài Flash, với Firefox 52 vào ngày 7 tháng 3 năm 2017. Tuy nhiên, Mozilla cung cấp một nhánh Phát hành Hỗ trợ Mở rộng, hay ESR, nhánh của trình duyệt Firefox. Trình duyệt này dành cho các tổ chức có nền tảng ổn định, lâu dài, chỉ nhận các bản cập nhật bảo mật, không phải là các bản cập nhật tính năng và thay đổi thường xuyên mà phiên bản chính của Firefox nhận được. Firefox 52 ESR được phát hành vào ngày 7 tháng 3 năm 2017 và bao gồm hỗ trợ cho các plugin trình duyệt không phải là Flash. Mozilla sẽ tiếp tục hỗ trợ Firefox 52 ESR với các bản cập nhật bảo mật cho đến khoảng quý 2 năm 2018. Vào thời điểm đó, phiên bản ESR tiếp theo của Firefox sẽ bỏ hỗ trợ cho các plugin NPAPI. Truy cập trang Tải xuống Firefox Extended Support Release để tải xuống phiên bản ESR của Firefox. Nếu bạn không chắc chắn nên tải xuống phiên bản nào, hãy chọn phiên bản Firefox 32 bit để tương thích tối đa với các plugin cũ hơn. Các plugin cũ hơn có thể không có sẵn phiên bản 64 bit. Bạn có thể xác minh bạn đang sử dụng phiên bản ESR của Firefox bằng cách nhấp vào menu> Trợ giúp>Firefox Hakkında. ESR güncelleme kanalındaysanız Firefox Firefox ESR’yi burada göreceksiniz.

MacOS < Span> java üzerindeki Safari’deki eklentiyi etkinleştirin. Güvenlik Güvenliği sekmesinde, tarayıcıdaki Java içeriğini etkinleştirmeyi etkinleştirin. Bu ayarları değiştirdikten sonra tarayıcınızı yeniden başlatmanız gerekebilir. Internet Explorer 11 ile çalışmayan ve Internet Explorer’ın eski bir sürümünü gerektiren eski bir web sitesini ziyaret etmeniz gerekiyorsa, Internet Explorer 11’in iş modunu kullanabilirsiniz. Ancak bu, Windows 10’un profesyonel sürümünü gerektirir. Ev versiyonunda mevcuttur.

Apple đã tắt plugin theo mặc định trong Safari trên macOS. Ngay cả Flash sẽ không phát theo mặc định và bạn sẽ phải bật nó bất cứ khi nào bạn truy cập trang web bạn muốn sử dụng Flash trên. Bất chấp những động thái mạnh mẽ này, Apple đã không gỡ bỏ hỗ trợ plugin NPAPI khỏi Safari – ít nhất là từ macOS Sierra 10.12. Safari tiếp tục hỗ trợ Java, Silverlight, Unity và các plugin dựa trên NPAPI khác. Trên thực tế, đây là trình duyệt hiện đại cuối cùng tiếp tục hỗ trợ các plugin này. Ngay cả khi bạn thường sử dụng Chrome hoặc Firefox trên máy Mac, bạn sẽ cần sử dụng Safari khi bạn muốn truy cập trang web yêu cầu plugin. Chúng tôi sẽ không ngạc nhiên khi thấy Apple hoàn toàn bỏ hỗ trợ cho các plugin trong phiên bản macOS trong tương lai. Nhưng Apple đã không công khai thời gian biểu cho việc này. Bạn có thể sử dụng các plugin này một cách bình thường trong Safari. Bạn sẽ phải kích hoạt chúng trước. Để làm như vậy, cài đặt plugin bình thường. Ví dụ: bạn có thể tải xuống Java từ trang web của Oracle. Đi tới Safari> Tùy chọn> Bảo mật>Mozilla Firefox ESR’yi Windows, MacOS veya Linux’a yükleyin

Firefox Hakkında. ESR güncelleme kanalındaysanız Firefox Firefox ESR’yi burada göreceksiniz.

MacOSJava’daki Safari’deki eklentiyi etkinleştirin. Güvenlik Güvenliği sekmesinde, tarayıcıdaki Java içeriğini etkinleştirmeyi etkinleştirin. Bu ayarları değiştirdikten sonra tarayıcınızı yeniden başlatmanız gerekebilir. Internet Explorer 11 ile çalışmayan ve Internet Explorer’ın eski bir sürümünü gerektiren eski bir web sitesini ziyaret etmeniz gerekiyorsa, Internet Explorer 11’in iş modunu kullanabilirsiniz. Ancak bu, Windows 10’un profesyonel sürümünü gerektirir. Ev versiyonunda mevcuttur.

Mozilla Firefox ESR’yi Windows, MacOS veya Linux’a yükleyin

Firefox Hakkında. ESR güncelleme kanalındaysanız Firefox Firefox ESR’yi burada göreceksiniz.

MacOS’ta Safari’deki eklentiyi etkinleştirin

Eklentiyi kurun. Kullanmak istediğiniz yüklü eklentiyi etkinleştirin. Eklentiyi tüm siteler için veya yalnızca belirli siteler için etkinleştirebilirsiniz. Örneğin, Safari oluşturmak için, ziyaret ettiğiniz bir web sitesi her istediğinde eklentiyi kullanmak isteyip istemediğinizi sorun, eklentiyi seçin ve ardından tercihleri ​​ayarlayın. Asıl çözüm, elbette, eklenti gerektiren web içeriğinden geçiş yapmaktır. Java, SIlverlight ve Unity ile oluşturulan uygulamalar, bir web tarayıcısının dışında da düzgün şekilde çalışır. Java veya Silverlight ile yazılmış masaüstü uygulamaları güvenlidir ve düzgün çalışmalıdır. Web tarayıcılarına video teslimi için Microsoft şu anda kendi Silverlight eklentisi yerine HTML5 video önermektedir. Netflix, en ünlü Silverlight kullanıcısıdır ve platformlar arası HTML5 video için Silverlight’ı terk etmiştir. Flash hala popüler, bu yüzden balta kullanılıyor. Ayrıca varsayılan olarak Chrome ve Edge’e entegre edilmiştir ve korumalı alanın güncel ve güncel kalmasına yardımcı olur. Ancak Flash bile bir gün sonra geride bırakılabilir. Firefox 52 sürümünde, Mart 2017’de yayınlandı, Adobe Flash Player’da Firefox’ta NPAPI desteğini aldı. Firefox’ta popüler uygulamalar, Silverlight, Java ve Adobe Acrobat’ta en yaygın kullanılan yazılımlardır. Web API’sini kullanarak, Web API’sini nasıl kullanabilirsiniz? Интернет полон веб-сайтов, которые выходят за рамки статичных страниц агают видео, музыку . отя NPAPI-плагины, в частности, Flash, помогали воплощать акие интерактивные страницы, они делают просмотр более медленным, безопасным олее подверженным падениям. Firefox’un, Web API’sini kullanarak uygulama yazılımlarını geliştirmeyi başardığı yaygın bir uygulamadır. Web API, koruma, koruma ve güvenlik önlemlerini almak için NPAPI uygulamalarını destekler. о этого, поскольку Web API не были до конца готовы, Firefox ачал переход путем агрузки плагинов вручную обходимости (путём активации по щелчку мыши). Web API’sini geliştirmenin bir yolu olarak, uygulama yazılımlarını nasıl geliştireceğinizi öğrenin. Firefox оединяется овременным аузерам,

Google Chrome ve Microsoft Edge gibi, NPAPI-Plane desteğinin sona ermesi. Mümkünse Firefox’u güncellemenizi öneririz. Her Firefox güncellemesi, internette güvende kalmanıza yardımcı olan iyileştirmeler de dahil olmak üzere önemli düzeltmeler ve iyileştirmeler içerir. Firefox da dahil olmak üzere herhangi bir tarayıcının eski sürümünü kullanmak kişisel verileriniz ve hatta bilgisayarınız riski altındadır. Firefox, ek eklentiler gerektiren işlevler için ileri desteğe sahiptir. Eklentiler, ayrıca geçerli durumda otomatik olarak desteklenir ve ek güvenlik için kilitler listesi ile kontrol edilir. Bu nedenle, yalnızca Firefox güncellemesini kullanarak güvenli kalabilirsiniz. KO ’…

Pytyvõreigua

Ekakua ha emoheraku nerembiapokue ambuéndi. Embohovái porandu ha Embotuichave cevheri kuaapy. Kullanıcılar dosya sistemine erişmek için kurumsal web uygulamam Java Apple. Şimdilik başka bir şeyle değiştirmemizin bir yolu yok. Microsoft Edge’de Java’yı nasıl etkinleştiriyorum?

  • 6 Cevaplar 6
  • Diğer insanların olduğu gibi, Java, ActiveX, Silverlight, Tarayıcı Yardımcı Nesneleri (BHOS) ve diğer eklentiler Microsoft Edge’de desteklenmez. Modern tarayıcıların çoğu eklentilerden ve standart HTML5 kontrolleri ve teknolojilerine doğru ilerliyor. Java eklentisini kurumsal bir web uygulamasında kullanmaya devam etmeniz gerekiyorsa, siteyi bir Kurumsal Modu sitesi sitesi sitesine eklemeyi düşünün. Bu Willia, kullanıcıyı otomatik olarak IE’de açmasını ister. Microsoft Edge’de Java uygulamalarını (veya diğer NPAPI eklentisini) açamazsınız – desteklenmez ve gelecekte eklenmez. Ayrıca, Google Chrome’un (V45 – Eylül 2015) bir sonraki sürümünde NPAPI eklentilerinin de desteklenmeyeceğini biliyorsunuz.

İş aralıkları

  • Yapabileceğiniz birkaç şey var: Internet Explorer 11 kullanın Windows 10’da zaten Internet Explorer 11 Intalleld. IE 11, NPAPI’yi (Java uygulamaları dahil) desteklemeye devam eder. IE11 sincap olarak uzaklaştırılır (C: \ Program Files \ Internet Explorer \ iExplore. exe). Kolay erişim için bu exe’yi görev çubuğunuza sabitleyin. Firefox’u kullanın, Win10’da bir Firefox 32-bit Genişletilmiş Destek Sürümü’nü kurabilir ve kullanabilirsiniz. Firefox varsayılan olarak NPAPI’yi devre dışı bıraktı, ancak bu geçersiz kılınabilir. Bu yalnızca 2018’in başlarına kadar desteklenecektir. Firefox sürüm 52, Firefox’ta NPAPI-Plane tarafından yüklenen, Adobe Flash Player dışında desteklenmez. Firefox’taki bu desteklenmeyen eklentilerden biri, bilgisayarınıza yüklenmiş olsalar bile Silverlight, Java ve Adobe Acrobattır. Son birkaç yıldır, Firefox, web sitelerinin eklentiler yardımı olmadan önceki işlevlerini ve görevlerini yerine getirebileceği çeşitli Web API’leri uyguladı ve büyük olasılıkla bir tarayıcı kullanırken herhangi bir değişiklik fark etmeyeceksiniz. İnternet, statik sayfaların kapsamının ötesine geçen ve videolar, müzik veya oyunlar sunan web siteleriyle doludur. NPAPI-Plan, özellikle Flash, bu tür etkileşimli sayfaların somutlaşmasına yardımcı olmasına rağmen, izlemeyi daha yavaş, daha az güvenli ve düşmeye daha yatkın hale getiriyorlar. Son birkaç yıldır, Firefox ekibi, Web API adlı eklentilerin bir yerine oluşturmak için çok çalıştı. Web API’leri, tarayıcının güvenlik, stabilitesi ve hızını ihlal etmeden NPAPI eklentilerinin işlevlerini değiştirmek için tasarlanmıştır. Bundan önce, Web API’sı tam olarak hazır olmadığından, Firefox, eklentileri gerekirse manuel olarak yükleyerek geçişe başladı (fare tıklamalarını etkinleştirerek). Artık birçok site Web API’sını destekliyor ve eski ve güvenli olmayan eklentiler kullanmadan neredeyse tüm favori sitelerinizi görüntüleyebilirsiniz. Firefox, NPAPI-Plane desteğinin sona ermesi için Google Chrome ve Microsoft Edge gibi diğer modern tarayıcılara katılır. Mümkünse Firefox’u güncellemenizi öneririz. Her Firefox güncellemesi, internette güvende kalmanıza yardımcı olan iyileştirmeler de dahil olmak üzere önemli düzeltmeler ve iyileştirmeler içerir. Firefox da dahil olmak üzere herhangi bir tarayıcının eski sürümünü kullanmak kişisel verileriniz ve hatta bilgisayarınız riski altındadır. Firefox, ek eklentiler gerektiren işlevler için ileri desteğe sahiptir. Eklentiler,
  • Ayrıca, geçerli koşulda otomatik olarak desteklenir ve ek güvenlik için kilit listesi aracılığıyla kontrol edilirler. Bu nedenle, yalnızca Firefox güncellemesini kullanarak güvenli kalabilirsiniz. Bu iyi insanlar bu makaleyi yazmaya yardımcı oldu:

Gönüllü olmak

Büyüyün ve uzmanlığınızı başkalarıyla paylaşın. Soruları cevaplayın ve bilgi tabanımızı geliştirin. Doğrudan tarayıcının ProxySG veya Gelişmiş Güvenli Ağ Geçidi (ASG) yönetim konsolu, “Tarayıcı artık Supapi eklentisi yok” veya “Bu eklenti giriş” veya “Bu eklenti” veya “Bu eklenti” mesajlarıyla başarısız oluyor Veya “bu pis piginProxySG veya Gelişmiş Güvenli Ağ Geçidi Yönetimi Konsolu’na erişim, “Tarayıcı artık NPAPI eklentisini desteklemiyor” veya “Bu eklenti desteklenmez” mesajlarıyla başarısız olur.

NEDEN

NPAPI eklentisi desteği 42 sürümünde varsayılan olarak devre dışı bırakıldı.

NPAPI eklentisi desteği 45 ve sonraki sürümlerde kaldırıldı.

Mozilla Firefox:

  1. NPAPI eklentisi desteği, 52 sürümünde varsayılan olarak devre dışı bırakıldı.
  2. NPAPI eklentisi desteği 53 ve sonraki sürümlerde kaldırılacaktır.
  3. Not: Symantec, Canagement konsolunu doğrudan bu NPAPI eklentisi kaldırmasından etkilenmeyen tarayıcılar destekler. SGO’lar ve Gelişmiş Güvenli Ağ Geçidi için Desteklenen Java, İşletim Sistemi ve Tarayıcı Sürümlerine bakın

Çözünürlük

  1. Doğrudan tarayıcı erişiminden, tüm yönetim konsolu etkinlikleri için Java Web Start’ı kullanmaya geçiş. Bunu yapmak, tarayıcı davranışındaki gelecekteki değişikliklerin yönetim konsolunun erişilebilirliğini etkilememesini sağlar. Java Web Start’ı kullanma ile ilgili ayrıntılar için, birden çok yönetim konsolu başlatmak için Yönetim Konsolu başlatıcısı JNLP dosyasını indirin
  2. Geçici çözüm
  3. Yönetim konsoluna doğrudan NPAPI eklentisi için desteği kaldıran veya devre dışı bırakan bir tarayıcı kullanılarak erişilmesi gerekiyorsa uygun geçici çözümü kullanın.

Şu anda Google Chrome sürüm 44 NPAPI eklentisi desteği 42’den 42’den 44’e kadar sürümlerde devre dışı bırakıldı. NPAPI Plupin desteğini etkinleştirmek için:

Tarayıcı adres çubuğunda: Chrome: // Flags/#ENABLE-NPAPI

NPAPI Etkinleştir bölümünde, Etkinleştir bağlantısını tıklayın.

Yapılandırma sayfasının altında, tarayıcıyı yeniden başlatmak için yeniden başlat düğmesine tıklayın.

Mozilla Firefox sürüm 52 NPAPI eklentisi desteği Currenning ise, 52 sürümünde varsayılan olarak devre dışı bırakıldı. NPAPI eklentisini etkinleştirmek için:

Tarayıcı adres çubuğunda, Gir: Hakkında: Config

Yeni boolean dizesi ekleyin “eklenti. load_flash_only” ve düşecek şekilde ayarlayın.

Tarayıcıyı yeniden başlatın.

Not: Firefox ESR sürüm 52’deki NPAPI desteği şu anda ProxySG veya Gelişmiş Güvenli Ağ Geçidi Yönetim Konsolu ile uyumlu değildir.